I have metrologic sp5700 optimus and i use a application on it that i need to send data to the server via gprs. When i send a data from the app it used to automatically connect the gprs, so i dont neet to go to Start>Settings>Network And Dial-Up Connection. But now it wont work like that, when i press to send data from app to the server the gprs start to connect and show me a message "You have been disconnected from the remote computer or baud rate. Please try again later" so i need to quit the app to go in Start>Settings>Network And Dial-Up Connection to connect the gprs and then to go back to app again. I checked Baud Rate it's ok.